OPEN TEXT eDOCS DM
VERSION 5.2.1 CU2

RELEASE NOTES

03/31/2009
LAST UPDATED: 03/31/2009

OPEN TEXT



Open Text eDOCS DM

Release Notes

Rev.: 31-Mar-09

Open Text Corporation

275 Frank Tompa Drive, Waterloo, Ontario, Canada, N2L 0A1

Tel: +1-519-888-7111

Toll Free Canada/USA: 1-800-499-6544 International: +800-4996-5440
Fax: +1-519-888-0677

E-mail: support@opentext.com

FTP: ftp:/ / ftp.opentext.com

For more information, visit http:/ /www.opentext.com

Copyright © 2008 by Open Text Corporation

Open Text Corporation is the owner of the trademarks Open Text, The Content Experts, Great Minds Working Together,
Livelink, Livelink ECM, Livelink ECM-eDOCS, Livelink MeetingZone, MeetingZone, B2BScene, B2BScene.com, Client/Surfer,
Collaboration, Creative Desktop, Further Faster, Hyperinnovation, Internet Anywhere ,Livelink IRIMS, IRIMS, IXOS, Livelink
OnTime, OnTime, Livelink Remote Cache, Microstar, MyLivelink, O & Design, Odesta, Odesta Helix, Odesta Livelinke, Open
Text Intranet, Open Text Web Index, Personality +, Putting Knowledge To Work, Techlib, The Hyperlinked Organization, The
Source For Business Knowledge, Worksmart, and World Of E among others. This list is not exhaustive.

ACKNOWLEDGEMENTS
SAP®, R/3® and SAP ArchiveLink® are registered trademarks of SAP AG.
Adobe® is a trademark of Adobe Systems Incorporated.

Lotus® and Lotus Notes® are registered trademarks of Lotus Development Corporation. Domino is a trademark of Lotus
Development Corporation.

Microsoft® and Microsoft SQL® are either registered trademarks or trademarks of Microsoft Corporation in the United States
and/ or other countries.

Oracle® is a registered trademark of Oracle Corporation.

Netscape and the Netscape N and Ship's Wheel logos are registered trademarks of Netscape Communications Corporation in
the U.S. and other countries.

Firefox® is a registered trademark of the Mozilla Foundation.
Sentry Spelling-Checker Engine Copyright © 2000 Wintertree Software Inc.
WordNet 2.0 Copyright © 2003 by Princeton University. All rights reserved.

Outside In® Viewing Technology © 1992-2002 Stellent Chicago, Inc. All rights reserved. Outside In® HTML Export © 2002
Stellent Chicago, Inc. All rights reserved.

Portions of eDOCS DM are copyrighted by DataDirect Technologies, 1991-2002.

All other products or company names are used for identification purposes only, and are trademarks of their respective
owners. All rights reserved.


mailto:support@opentext.com
ftp://ftp.opentext.com/
http://www.opentext.com/

Table of Contents

Ta Lo Yo [¥To3 AT o] o FO RPN 5
1.1 Contact INfOrMAatiON..........oiiiiiie e 5
About Open Text eDOCS DM 5.2.1 CU2 ....ovvciiiiiiiiiiiieee e 7
2.1 General INfFOrMALtION .......oooiiiiiiie e 7
Packaging and DOCUMENTALION .........uuuuueiiiiiiiiiiiiiiiiiiieeriiineeeinereeneeeeneeneeenees 9
3.1 DOCUMENTALION ...eeiieiiiiiee ittt e s e e e e e e eeeeaeeeas 9
3.11 Documentation UPAALES ..........ccviirieirierieiienee et 9
3.1.2 Windows Help (WinHelp) Not Included in Windows Vista...........ccccoccvvnenen. 10
Installation and Upgrade NOTES ...........uuuuiiiiiiiiiiiiiiiiiiiiiiiiieieiiiiiiieneeeeiennnes 11
4.1 Running Library Generator ..........cccccccveveveiiieieeeeeeeeeee e 11
4.2 DIM SEIVET ... 12
4.3 DM WED SEIVEN ...ttt 13
4.4 DM WOTKFIOW SEIVET ..ottt 13
4.5 DM EXIENSIONS SEIVEr SEIUP .....vviieiiiiiee ettt 14
4.6 RM AdMINIStration TOOI..........cooiiiiiiiiiiie e 14
4.7 Installing DM Imaging on Windows Vista..........cccccoviieiiniee e 14
Configuration NOTES ......oouiiiiiii e eeeaeaaees 15
51 Enhancing Application Integration Stability............cccoceeiiiiiiiniieenee 15
5.2 Addressable FOIAErS .......ooiiiie e 16
5.3 Implementing Content Cache ... 16
5.4 DM Extension for LOtUS NOLES ...........eeiiiiiiiiiiiiiiiieeeee e 17
55 DM Extensions APl CONNECHIONS .......coiiiiiiiiiiiiiiie e 17
5.6 DM Indexer ConSIderations ..........cc.ueeiveeeeeiiiciiieiee e e seieee e e 17
5.7 DYyNamiC VIEWS.......ccooviiiiiiiie e 18
57.1 Converting from DVDP in DM 5.1.0.5 to Dynamic Views in DM 5.2.1......... 18
572 SEAICH ODJECLS. ...t 18
573 Last Edit Date/Time DeVIiation .........cccceverevieninnieeieieenese e e see e 19
5.8 Microsoft Office 2007 .......ueeiiieeeeiiieiie e 19
5.8.1 Microsoft Excel COM Automation Using Non-English Regional Settings..... 19
5.8.2 Ensuring Application Integration Works When You Do Not Install All

Microsoft Office 2007 APPIICALIONS ........ooveiiiieiiee e 19

Open Text eDOCS DM Version 5.2.1 CU2 Release Notes iii



5.9 NET FrameWork 2.0 ..o 20
5.10 Oracle Hybrid Searching..........ccoouveiiiiiiiiiiiiiec e 20
5.11 Save User Interface Behavior with RM File Parts...........ccccocoeeiiiineennns 20
5.12 Support for Microsoft Office XP ......occciiieeiiei e 21
5.13 Support for Microsoft SQL Server 2005..........ccooiiiieiiiiieeniiieee e 21
5.14 Support for Microsoft Windows 2003 Server SP1 .........cccoeccvvveeeeeeinins 21
5.15 Support for Oracle 10g Release 2 ..........oeeiiiiiiiiiiiieeeiieee e 21
5.16 Update Deployment Packages Created Prior to DM 5.2.1 .................... 22
5.17 Upgrading or Changing Integration Methods.............cccccevviiiiiiiieeenen 22
5.18 User Account Control (UAC) Setting in Windows Vista.............cccccc..... 23
5.19 Visual CH+ 2005 SPL....ccouiiiiiiiiiiie i 23
Fixed Issues and KNOWN ISSUBS ........uuuiiiiiiiiiiiiiiiiiise et eeeeeaeees 25
6.1 FIXEA ISSUBS ...t 25
6.2 Fixed Issues in Previous Releases........cccccoovuvvveeiieee i 25
6.3 KNOWN ISSUES .....coiiiiiiiieiei ettt 26
6.3.1 ApPlication INTEGratioN...........ccooeiiiiiiiieree e 26
6.3.2 DIM EXEENSIONS ...ttt bbbttt bbbt be e 26
6.3.3 A 17 1ol 1< PSSR 26
6.3.4 DM WOTKFIOW ...t 27
6.3.5 DM Administration TOOIS ........ccceiiiiriiiiiesese e 27
6.3.6 DIM WEDTOP ...ttt s 27
IMAge NUMDBEIS ..o e e e e eaeees 29
7.1 DM SEIVET .t 29
7.2 DM WED SEIVE ..ottt 29
7.3 DM WOIKFIOW SEIVET ...t e e 29
7.4 DM WorkFlow Server Language PacK..........cccccccvveviiiiiiii 29
7.5 DM EXteNSIONS SEIVEr SEIUP ......vvvieiiiiie ettt 30
7.6 RM AdmINistration TOOI.........cceeiiiiiiiiiiiie e 30
7.7 Automated E-mail Management ............ccccoeveii 30
FIlES DEIIVEIEA ... uueii et e e e e et e e e e e e e aaannes 31

Open Text eDOCS DM Version 5.2.1 CU2 Release Notes



Chapter 1

Introduction

The following release notes state known problems and last minute changes to Open Text eDOCS
DM Version 5.2.1 CU2. We recommend that you read these Release Notes in conjunction with the
documentation included with the software package. If any conflicts exist, the Release Notes
supersede the other documentation.

Check the Open Text Knowledge Center at (https://knowledge.opentext.com/) for any patches or
documentation updates that may have been posted after the initial release of this version of DM 5.2.1
Cu2.

1.1 Contact Information

Open Text Corporation
275 Frank Tompa Drive, Waterloo, Ontario, Canada, N2L 0A1

Tel: +1-519-888-7111

Toll Free Canada/USA: 1-800-499-6544 International: +800-4996-5440
Fax: +1-519-888-0677

E-mail: support@opentext.com

FTP: ftp:/ / ftp.opentext.com

For more information, visit http:/ /www.opentext.com
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Chapter 2
About Open Text eDOCS DM 5.2.1 CU2

2.1 General Information

The DM 5.2.1 CU2 release is cumulative and contains everything that earlier DM 5.2 and 5.1.0.5
service or maintenance releases contained, plus any new modifications.

These service releases automatically detect the products you have installed and apply service
releases accordingly. For example, if you have DM Server but do not have RM Server, only DM
Server service releases will be applied.

Service releases within this set may have interdependencies. If you encounter issues, be sure that
you have applied all service releases in this set and continue to reproduce the problem before
contacting Technical Support.

Please see Fixed Issues and Fixed Issues in Previous Releases for details on the public patches
included in this release.
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Chapter 3

Packaging and Documentation
3.1 Documentation

The documentation and help files in DM 5.2.1 CU2 are those delivered with DM 5.1.0.5 SR1. Consult
these for the core documentation set; however, you must also read the following documents to
obtain new or corrected documentation:

e New Documentation —The Open Text - Using eDOCS DM 5.2x Software document contains
specific information related to this release, including using Microsoft Office 2007, Windows
Vista, Dynamic Views, DM Extension for Lotus Notes, and the new save user interface. This
new information is not located within the original core documentation set.

e New Documentation and Updates — The DM/RM 5.x Documentation Updates document
contains new and updated documentation since the original release of DM 5.1.0.5 and DM
5.2, including information as a result of service releases and maintenance releases. This
document also contains clarifications to existing documentation.

3.1.1 Documentation Updates

The following topics have been added to the DM/RM 5.x Documentation Updates document for the
DM 5.2.1 CU2 release:

DM Administration Guide
e Using the .pea File for EMC Centera Read-Only Document Servers
e Using the SaveSeparately Registry Key to Select or Clear the Save Separately Check Box

DM Extensions API Reference Guide
e New Version of the IBCEnumObijects Interface
e Adding an Item to the Navigation Pane of the DM 5.2.x Save User Interface

Open Text eDOCS DM Version 5.2.1 CU2 Release Notes
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Using DM Extensions
e DM Passive Integration Menu Changes in Microsoft Office 2007 Applications

3.1.2 Windows Help (WinHelp) Not Included in Windows Vista

The Help files delivered with DM 5.2.1 were originally created in Windows Help (WinHelp) format.
The Windows Help format is not supported, nor included, with Windows Vista operating systems.

You can download the WinHelp.exe application and use it to view DM Help files on Windows Vista
operating systems. Download the Winhelp.exe application from Microsoft’s web site at the following
location: http:/ / go.microsoft.com/fwlink/?LinkID=82148.

However, the following known issue has been reported by Microsoft. When you open a Help topic
(by pressing F1 or by selecting Help>Contents and Index), the following error message appears:
“There was a problem running the macro. (1037).” After this initial error, you can continue using the
Help files.

For more information and workarounds to this issue, consult Microsoft’s Article ID 917607 at the
following location: http://support.microsoft.com/kb/917607.

The Help files do not contain any new information for DM 5.2.1 CU2. You must consult
the Open Text - Using eDOCS DM 5.2x Software and DM/RM 5.x Documentation Updates
documents for all new information pertaining to this release
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Chapter 4

Installation and Upgrade Notes

All updates in the DM 5.2.1 CU2 set are provided when you download dm52102.exe. When you
download the releases, they are by default extracted to C:\Program
Files\Hummingbird \ Enterprise 2004 Service Releases\DM 5.2.102\Build 37. You can change the
installation path, if you want. When the download is finished, the Hummingbird maintenance
release browser automatically launches. You can download the release set for each server that you
update, or you can download the release set to a shared network location. If you are running from a
network location, double-click \Enterprise2004 DM 5.2.102\ Build 37\setup.exe to launch the
maintenance release browser.

NOTE: As any combination of DM 5.x products can exist on one machine, you must apply the
DM 5.2.1 patch for each component.

All server updates include the DM API updates. The DM API updates are also included with the
DM Extensions updates for client machines.

In addition to the instructions that follow, please be sure to review the Configuration Notes and the
Fixed Issues and Known Issues lists for setup instructions that may be applicable to your DM
implementation.

4.1 Running Library Generator

If you are upgrading from a previous version of DM 5105, after you install DM 5.2.1 CU2, you must
run Library Generator (tblcomp.exe) in order for new and changed tables and columns to be
updated.

For a complete list of these tables and columns introduced in DM 5.2, consult the DM 5.2 Release
Notes. The “Database Schema Changes” section contains the descriptions and values for each table
and column.

Open Text eDOCS DM Version 5.2.1 CU2 Release Notes 11


http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf

4.2

DM Server

DM Server 5.1.0.5 SR1 or later must be installed before the updates can be applied. The maintenance
release installation will validate the licensing to determine which products are installed and only
update patched files.

On the DM Server being updated, from the maintenance release browser, click Install Products>DM

Server.

Installation Considerations

The DM Server maintenance release installation shuts down the DM Service, loads the
updated files, and restarts DM Server. If you cannot connect to clients after the update is
run, verify that the Server State in the DM Server Manager is Started. At the end of the DM
Server installation, you may receive a Reboot Required notice. Reboot the DM Server to
complete the installation.

Before installing the DM Server updates on a server that is indexing with SearchServer™, all
SearchServer indexes must be stopped through DM Server Manager and restarted after the
installation is complete.

If either DM Web Server or DM Extensions is installed on DM Server, it must be shut down
to release connectivity with the DM APL. For DM Extensions, close all applications and be
sure that Interceptor has also been closed. For DM Web Server, you must shut down the IIS
Admin Service in Control Panel>Services. After the maintenance release installation is
complete, remember to restart the IIS Admin Service and all appropriate Web services.

If InstallShield detects processes that cannot be released during the installation process, a
reboot will be required after the updated files are copied. After the reboot, all maintenance
release files will be updated. The Server Configuration Wizard may launch. If you do not
need to change your configuration, click Cancel.

If you need to Repair or Modify your DM Server installation, uninstall the software from
Control Panel>Add/Remove Programs. A reboot is required before you reinstall. When
reinstallation is complete, you will also need to reinstall applicable DM service or
maintenance releases.
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4.3 DM Web Server

DM Web Server 5.1.0.5 SR1 or later must be installed before the updates can be applied. The
maintenance release installation will validate the licensing to determine which products are installed
and only update patched files.

DM Extension Server Setup update must be run after updating DM Web Server in order to update
the DM Extensions.

On the DM Web Server being updated, from the service release browser, click Install Products>DM
Web Server.

Installation Considerations

If you currently have custom directories for your users or groups, you will need to copy the
appropriate files from the \Cyberdocs\Backup directory to your custom directories after the update
has been installed.

Hummingbird DM Web Server 5.2.102 can be uninstalled from Control Panel>Add/Remove
Programs.

Later, if you choose to Modify or Repair your DM Web Server installation from the CD image, you
will need to uninstall DM Web Server 5.1.0.5 SR1, make your Modify or Repair changes, and then
reinstall.

4.4 DM WorkFlow Server

DM WorkFlow 5.1.0.5 SR1 or later must be installed before the updates can be applied.

On the server being updated, from the maintenance release browser, click Install Products>DM
WorkFlow Server.

Installation Considerations
DM WorkFlow Server updates must be applied before updating the DM WorkFlow clients.

Later, if you choose to Repair or Modify your DM installation from the CD image, you will also need
to reinstall applicable the DM WorkFlow updates.
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4.5 DM Extensions Server Setup

DM Extensions Server Setup 5.1.0.5 SR1 or later must be installed before the updates can be applied.

On the server being updated, from the maintenance release browser, click Install Products>DM
Extensions Server Setup.

Installation Consideration

After the service release for the DM Extensions Server Setup has been installed, users can log on to
the DM Webtop to upgrade DM Extensions on the client machines.

4.6 RM Administration Tool

RM Administration Tool 5.1.0.5 SR1 or later must be installed before the updates can be applied.

On the server or workstation being updated, from the maintenance release browser, click Install
Products>Hummingbird RM Administration Tool.

Installation Note:

Later, if you choose to Repair or Modify your RM Administration Tool installation from the CD
image, you will need to reinstall the RM Administration Tool 5.1.0.5 updates.

4.7 Installing DM Imaging on Windows Vista

After you install DM Imaging on a Windows Vista operating system, you must apply a patch to the
client workstation. This patch is located in C:\Program Files\Hummingbird\ Enterprise 2004
5.2.102\Image 37\Tools\DM Extensions\Imaging directory. Copy all files to the ..\DM
Extensions directory.
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Chapter 5

Configuration Notes
5.1 Enhancing Application Integration Stability

In addition to specific fixes outlined in these Release Notes, DM 5.1.0.5 and subsequent releases
focused on enhancing application integration stability. In conjunction with the recommended
registry settings outlined below, significant improvements have been made in error handling related
to zero-byte files and other file save anomalies. These registry settings must be manually applied to
function correctly with DM 5.2.1. If DM detects that a save or upload process fails, an error message
will alert the user, the user will be notified in screen-displayed messages, and the Retry option will
occur until the file is saved successfully or the user cancels the action. If the native application's Auto
Recovery is activated by an application failure, analysis of the problem will be outside the scope of
DM error detection, and users should follow normal application procedures to recover their
document.

Manually apply the registry settings below:

[HKEY_CURRENT_USER\ Software\ Hummingbird\ PowerDOCS\ Core\ Plugins\ Fusion\ Settings]
"CheckFileSizeOnDownload"=dword:00000002

"CheckFileSize AfterUpload"=dword:00000001

"RetryUploadIfFailed"=dword:00000001

"RetryUploadDelay"=dword:0000000f

"UploadIfDifferentSizeOnDownload"=dword:00000001
"UploadIfDifferentSizeOnUnlock"=dword:00000001

NOTE: Additional information is available in Technical Bulletin #133277, “How to Avoid Missing
Edits and Zero-Byte Files in Hummingbird DM™”. This document is available in the Open Text
Knowledge Center at https:/ /knowledge.opentext.com.
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5.2 Addressable Folders

If you are sending e-mails via Addressable Folders to both primary and remote DM libraries, an
address for a primary library folder must be first in the list.

The DM SMTP Service cannot coexist on the same server where Microsoft or other SMTP services
are running,.

During installation of Addressable Folders, verify that the Administrative Tools dialog boxes
pertaining to server services are closed. If any are open, some services cannot be unregistered, and
the installation will not be successful.

5.3 Implementing Content Cache

As of DM 5.1.0.5 SR6, Content Cache was enhanced to allow users to save the document to a Content
Cache Server and then have immediate access to the document. The Cache Server handles
synchronization of document updates to the document server in the background. These actions can
greatly increase the efficiency of saving documents from a remote site.

Implementation of this optional enhancement requires running a SQL script and modifying a
registry entry. Complete the steps listed below.

To implement the Content Cache feature:

1 Using Microsoft SQL Query Analyzer, run the script content_cache.sql, which is located in the
\Tools\DM Server folder, for all Hummingbird DM libraries. If the owner of the library is not
DOCSADM, replace DOCSADM in the script with the database owner.

2 In DM Server Manager, verify that Commit Transaction Monitoring is enabled. On the Content
Cache tab, verify that Enable Content Cache is selected and the Content Cache settings are
correct.

3 Create the following values in the registry key on the DM Server machine:

[HKEY_LOCAL_MACHINE\ SOFTWARE\ Hummingbird\ DOCSFusion\ Content Cache]
"Cache"="Enabled"

"Max Size"=dword:000001f4

"Lazy Write"="Enabled"

"Location"="C:\ \ content_cache\ \"

4  Set the Location for your Content Cache.
5 Restart DM Server.
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5.4 DM Extension for Lotus Notes

Because each Lotus Notes document and e-mail message is associated with a Lotus Notes form
template, you should not archive, delete, or move the associated form. This form determines how
the document or e-mail message is displayed and becomes a related document in DM.

When a user opens a profiled Lotus Notes document, if the related profiled Lotus Notes form cannot
be located in DM, the document opens and uses the existing Lotus Notes form located in the Lotus
Notes database. This means that if the form has changed, the document will not render in its original
form.

You should advise your users not to delete the Lotus Notes form template documents.

55 DM Extensions APl Connections

In DM 5.1.0.5 SR6 and later, the DM Extensions API takes a new approach for tracking active DM
Extensions API connections. To bring their code into conformance with this new approach,
developers should introduce the following before using DM Extensions API interfaces:

Instantiate an object of either IBCSession or IBCSession2.

Call the method Logon (for IBCSession) or LogonEx (for IBCSession?2) if IBCBrowser object is not
available.

The session object can be released only when no more DM Extensions API usage is planned, or there
are other connected session objects.

5.6 DM Indexer Considerations

This release contains SearchServer 6.1.0.167. When upgrading from DM 5.1.0.5 SR6 MR5 or earlier,
you must create new indexes of your DM Libraries. We recommend that you configure one indexing
server to build your new indexes before deploying DM 5.2.1 to client workstations. Alternatively,
you can select previous releases of SearchServer indexes for client searching while you build the
indexes; however, these indexes must be static and cannot be updated by SearchServer 6.1.0.167
during the transition. You can also create indexes before rolling out the upgrade to clients.

The Hybrid Searches feature, which was introduced in DM 5.1.0.5 Service Release 5, can be
implemented in DM 5.2.1 CU2. The DM/RM 5.x Documentation Updates document contains
detailed instructions on implementing Hybrid Searches (Profile and Content searches) in the
“Improved Performance for Hybrid Searches” section. If you choose to implement Hybrid Searches
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with DM 5.2.1 CU2, apply the update before recreating your DM indexes. If you add Hybrid
Searches after you create your SearchServer 6.1.0.167 indexes, reindexing is required.

NOTE: Hybrid Searching is supported for MS SQL and Oracle DM libraries.

5.7 Dynamic Views
5.7.1 Converting from DVDP in DM 5.1.0.5 to Dynamic Views
in DM 5.2.1

DM 5.2 introduced a new version of Dynamic Views. When you install Dynamic Views 5.2.1 on the
client machine, the DM 5.1.0.5 version of Dynamic Views Dynamic Profiling (DVDP) is
automatically removed. Refer to the Using Open Text — eDOCS DM 5.2x Software document for
information on converting a current DVDP environment to the new Dynamic Views for 5.2. The
conversion process allows DVDP 5.1.0.5 clients (DM 5.1.0.5 SR5 and SR6) to continue using their
current version of DVDP until they are upgraded to DM 5.2.1.

5.7.2 Search Objects

In order for search objects to function correctly in Dynamic Views, the MSG_ITEM field must be
placed on the QBE search form (DEFQBE.FRM, GOVTQBE.FRM, BANKQBE.FRM, or
LAWQBE.FRM). When you create a new library, this process is done automatically; however, if you
upgrade a DM 5.1.0.5 library to DM 5.2.x, you must manually add this field to the applicable QBE
search form using DM Designer.

To add the MSG_ITEM field to the QBE search form:
1 Click Start>Programs>Hummingbird>DM Server>Server Admin Tools>DM Designer.
2 Click Profiles.

3 In the Available Forms dialog box, select your industry type’s QBE Search Form, and then click
OK. For example, select LAWQBE Legal QBE Search Form.

In the SQL Columns dialog box, select MSG_ITEM and drag it to the Search Form.
Release the mouse where you want the MSG_ITEM field to appear.

Select File>Save.

In the Save Form dialog box, click OK.

Select File>Exit to exit DM Designer.

© 00 N o o1 b~

Refresh the cache in DM Server Manager.
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5.7.3 Last Edit Date/Time Deviation

Dynamic Views Search objects return a last edit date/time that deviates one hour or more from the
actual edit date. This issue has been resolved in DM 5.2.1 CU2, however the LAST_EDIT_TIME
column must be added to the hit list in order for the fix to take effect. Be sure to refresh the DM
Server and Workstation caches for the changes to the form to appear.

5.8 Microsoft Office 2007

The Microsoft Office 2007 redistributables are required if you select Office 2007 integration. These
redistributables are installed automatically; however, they will not be removed when DM is
uninstalled from the machine.

5.8.1 Microsoft Excel COM Automation Using Non-English
Regional Settings

If you use active or passive COM Automation integration with Microsoft Excel, and your operating
system’s regional settings are set to non-English (United States), you must apply the Microsoft Office
Language Pack in order to save native .csv files.

The Microsoft Office Language Pack(s) are located on Microsoft’s web site at the following location:
http:/ / office.microsoft.com/en-us/downloads/ HA011133501033.aspx

5.8.2 Ensuring Application Integration Works When You Do
Not Install All Microsoft Office 2007 Applications

If you do not install all Microsoft Office 2007 Basic applications (Word, Excel, and PowerPoint),
application integration is broken; however, you can use a workaround to ensure that DM application
integration works after installing only one or two of the applications.

To implement the workaround:

1 In Control Panel>Add or Remove Programs, select Microsoft Office 2007 Primary Interop
Assemblies, and then click Remove.

2 Select Start>Run, type regedit, and then click OK.

3 In the Registry Editor, create the following registry keys:
i HKEY_CLASSES_ROOT\ TypeLib\ {00020813-0000-0000-C000-000000000046}\ 1.6
(Default) Value: Microsoft Excel 12.0 Object Library
T HKEY_CLASSES_ROOT\ TypeLib\ {00020905-0000-0000-C000-000000000046}\ 8.4
(Default) Value: Microsoft Word 12.0 Object Library
T HKEY_CLASSES_ROOT\ TypeLib\ {91493440-5A91-11CF-8700-00A A0060263B}\ 2.9
(Default) Value: Microsoft PowerPoint 12.0 Object Library
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4  Reinstall the Microsoft Office 2007 Primary Interop Assemblies using Microsoft’s redistributable
package. You should read the package’s readme for additional information. Download the
Microsoft redistributable package from Microsoft’s web site at the following location:
http://www.microsoft.com/downloads/details.aspx?FamilylD=59daebaa-bed4-4282-a28c-
b864d8bfa513&DisplaylLang=en

5.9 .NET Framework 2.0

The .NET Framework 2.0 is a prerequisite for all products and is included with the DM 5.2.1 CU2
release. To install, navigate to ...\Tools\Redistributables\MS_NET_2.0.

You must install .NET Framework 2.0 on both the client and server machines.

5.10 Oracle Hybrid Searching

Oracle is supported in hybrid searching. The hybrid search enhancement changes the way in which
the INDEX table uses metadata when performing a hybrid search, which is a search that contains
both profile and content search criteria.

The following files are delivered in the \Enterprise 2004 5.2.102\Tools\DM Server\Profile-
Content Search directory:

e Oracle_indexed_columns_dm.sql - This should be run on a DM-only server where RM is
not installed.

e Oracle_indexed_columsn_rm.sgl - This should be run on a DM/RM server.
Run the appropriate file depending on your setup.

For complete instructions on using hybrid searching, for both Oracle and Microsoft SQL databases,
consult the "Improved Performance for Hybrid Searches" section in the DM/RM 5.x Documentation
Updates document.

511 Save User Interface Behavior with RM File Parts

When a user saves to a RM file part, that file part will not appear in the Location drop-down menu
unless the user has previously browsed the file part in the save user interface or through DM
Extensions.
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For example, when a user starts an integrated application and saves a document to a RM file part,
while the DM session is active, that file part will appear in the Location drop-down menu. However,
once the user exits and restarts DM, the file part will not appear.

5.12  Support for Microsoft Office XP

Although Microsoft Office XP is not listed as a supported application for DM 5.2.1 CU2, we have
performed minimal testing with Microsoft Office XP and determined that integration is possible.

Open Text encourages customers to upgrade to Microsoft Office 2003 or Microsoft Office 2007 before
deploying DM 5.2.1 CU2; however, if that is not possible, we will continue to accept support cases
from customers using DM 5.2.1 CU2with Microsoft Office XP.

Consult the Using Livelink ECM - eDOCS DM 5.2x Software guide for the “Supported Applications
and Platforms in DM 5.2” chapter.

5.13  Support for Microsoft SQL Server 2005

Support for Microsoft SQL Server 2005 is provided in compatibility mode and can be attained by
running Library Generator against the database. Locate the tblcomp.exe file in the ..\Program
directory.

5.14  Support for Microsoft Windows 2003 Server SP1

Support for Windows 2003 Server SP1 began in DM 5.1.0.5 SR5. With the installation of DM 5.2 or
greater, the necessary files are delivered for support of Microsoft Windows 2003 Server SP1. You will
need to run the DM Server Configuration Wizard after applying the 2003 Server Service Release.

5.15 Support for Oracle 10g Release 2

Support for Oracle 10g Release 2 is provided with DM 5.2.1. No further action is required after you
run Library Generator to upgrade from DM 5.1.0.5 to DM 5.2.1.

Oracle 10G Release 2 is supported with the following Oracle patches installed:
¢ Oracle 10g Release 2 patch set 10.2.0.3.0 (Oracle patch number 5337014)

¢ Oracle ODBC drop-ins (Oracle patch number 5699495)
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Please contact Oracle support for additional information. Note that these patches are included with
Oracle 11G.

5.16 Update Deployment Packages Created Prior to DM
5.2.1

Any deployment Packages that were created prior to DM 5.2.1 will need to be updated. Edit your
existing deployment packages, re-enter your administration credentials, select the correct
components, and execute a Save before using the package.

After you install DM 5.2.1 CU2, you should run the Deployment Package Wizard and resave all
deployment packages that use the “Run as Administrator” option.

To resave a deployment package:

1 Click Start>Programs>Hummingbird>DM Extensions Server Setup>Deployment Package
Wizard.

2 Select a deployment package that has the Run as Administrator option enabled, which is
displayed in the Details box.

Click Edit to edit the deployment package.
4  In the Location Information dialog box, click Next.

5 In the User Information dialog box, type the administrator credentials to be used by the
deployment package, and then click Next.

6  Continue clicking Next on all subsequent dialog boxes, and then click Save.

7 Repeat the above steps for all deployment packages using the Run as Administrator option, and
then exit the wizard.

5.17 Upgrading or Changing Integration Methods

When you upgrade or change your integration method (ODMA, COM, Passive, Active, or
Interceptor) for an application, some menu items might be unavailable, appear twice, or do not work
as expected.

This is working as designed to prevent other potential integration issues, such as performance
issues, conflicts with third-party macros, and saving and read-only issues with the normal.dot file in
Microsoft Word. You can resolve this issue by resetting the toolbars. In addition be sure to verify
that your launch methods are correct as they can vary between application versions.

To resolve the menu issue:
1 Start the application that has unavailable, duplicate, or non-functioning menu options.

2 Select Tools>Customize.
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3 In the Toolbars tab, select Standard, and then click Reset.
4  Select Menu Bar, and then click Reset.

5 In Microsoft Word, click OK when you are prompted to reset changes in the normal.dot file.
NOTE: Customizations to the toolbar will be lost by resetting the toolbar.

5.18 User Account Control (UAC) Setting in Windows
Vista

The User Account Control (UAC) setting in Windows Vista operating systems is enabled by default.
The following issues occur with this setting enabled:

e Error message appears when attempting to install DM Extensions from DM Webtop (DM-
9640)

e DM Extensions cannot be launched if the Client Deployment Ultility is launched first (DM-
10730)

e A DM Server that is added from the DM Extensions Login screen is not retained (DM-10726)

For more information about the UAC setting, please consult the Microsoft support site at
http:/ /support.microsoft.com.

5.19 Visual C++ 2005 SP1

The Visual C++ 2005 SP1 redistributables are a prerequisite to DM Extensions, DM Server, and all
server-side products that require the DM API. For server-side patch installations, the DM
administrator should be prompted to install this redistributable.

For DM Extensions, the user will be prompted only for interactive installations. This redistributable
will not be removed when DM is uninstalled from the machine.
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Chapter 6

Fixed Issues and Known Issues

Following is a list of the issues resolved in DM 5.2.1 CU2. For more information on an issue, go to
the Open Text Knowledge Center and search on the Key number (such as DM-4124), which can be

found at the beginning of the title, or you may contact Technical Support.

6.1

Fixed Issues

Click here for a list of all fixed issues in this release.

6.2

Fixed Issues in Previous Releases

You should review the Fixed Issues for all releases between the one you are upgrading from and this
release. You can find this information in the following documents:

DM 5.1.0.5 Service Release 1 Release Notes

DM 5.1.0.5 Service Release 2 Release Notes

DM 5.1.0.5 Service Release 3 Release Notes

DM 5.1.0.5 Service Release 4 Release Notes

DM 5.1.0.5 Service Release 4 Maintenance Release 1 Release Notes

DM 5.1.0.5 Service Release 4 Maintenance Release 2 Release Notes

DM 5.1.0.5 Service Release 4 Maintenance Release 3 Release Notes

DM 5.1.0.5 Service Release 4 Maintenance Release 4 Release Notes

DM 5.1.0.5 Service Release 5 Release Notes

DM 5.1.0.5 Service Release 5 Maintenance Release 1 Release Notes

DM 5.1.0.5 Service Release 5 Maintenance Release 2 Release Notes

DM 5.1.0.5 Service Release 5 Maintenance Release 3 Release Notes

Open Text eDOCS DM Version 5.2.1 CU2 Release Notes

25


https://knowledge.opentext.com/
https://knowledge.opentext.com/knowledge/llisapi.dll/fetch/2001/3551049/11569762/11568658/customview.html?func=ll&objId=11568658&objAction=browse&viewType=1#DMRM52
https://knowledge.opentext.com/knowledge/llisapi.dll/12826460/DM_5.1.0.5_-_DM_RM_5.1.0.5_Service_Release_1_Release_Notes.html?func=doc.Fetch&nodeid=12826460&viewType=1
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR2.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR3.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR1.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR2.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR3.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR4.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR5.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR5MR1.html
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e DM 5.1.0.5 Service Release 6 Release Notes

e DM 5.1.0.5 Service Release 6 Maintenance Release 1 Release Notes

e DM 5.1.0.5 Service Release 6 Maintenance Release 2 Release Notes

e DM 5.1.0.5 Service Release 6 Maintenance Release 3 Release Notes

e DM 5.1.0.5 Service Release 6 Maintenance Release 4 Release Notes
e DM 5.2 Release Notes

e DM 5.2.1 Release Notes

e DM 5.2.1 HotFix 1 Release Notes

e DM 5.2.1 CUI Release Notes

6.3 Known Issues
6.3.1 Application Integration

e DM-16665 - After installing eDOCS DM integration with Excel 2007, the Quick Access
Toolbar becomes read-only. This issue is currently being investigated with Microsoft.

6.3.2 DM Extensions

e DM-16753 - Read-only fields that are linked to lookup fields, and thus populated when the
lookup field is updated, do not appear to be read-only, allowing you to edit them. An
example of one of these fields is the Author Name field that is displayed when you choose
an Author ID from the profile form lookup. This problem is an interface problem on the
client workstation and any changes made to the read-only fields are not updated on the
server.

6.3.3 Attaché

e DM-16558 - Open, Print and Delete Options are grayed out in the right-click context menu
when working in DM Offline mode within Outlook Extensions. As a workaround, use
Explorer Extensions.
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6.3.4

6.3.5

6.3.6

DM Workflow

DM-16748 - In DM Workflow in Outlook, if the user double clicks on a task from the
Incoming tasks folder and clicks Done to finish the task from that dialog, then Outlook will
hang. The issue is that Outlook is not able to process notifications until workflow process is
completed. The issue happens only if you click on the 'Done' button from the Task dialog.

Workaround: Right click the task from the Incoming tasks folder and click 'Done' menu, the
task will be completed successfully.

DM Administration Tools

DM-14381 - When using addlib.exe, database triggers are not being created when the new
library is generated. This problem does not occur when creating a new library using
tblcomp.exe. A workaround is provided for English only environments. Copy addlib.exe
from the ... \Tools\ DM Server\ Program\ ENU directory and replace the one located on the
DM Server. Be sure to backup the original addlib.exe by renaming it first.

DM Webtop

DM-16730 - If you attempt to create a paper document in the webtop by choosing New
Document, then select the Paper tab and fill out the profile form, when you click the “Create
Document” icon an error will appear “The problem may be due to a user input error, to a
DM Server processing or communications error, or to an internal Hummingbird DM error.
Update failure when trying to UNLOCK document - unlocked. This does not occur in DM
Extensions.
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Chapter 7

Image Numbers

7.1 DM Server

DM Server 5.2.1 5.2.102.16
DM Administration Tools 5.2.1 5.2.102.1
RM Server 5.2.1 5.2.102.16
DM API5.2.1 5.2.102.16
7.2 DM Web Server
DM Web Server 5.2.1 5.2.102.4
DM Web Administration Tools 5.2.1 5.2.102.4
DM API5.2.1 5.2.102.16
RM Web Server 5.2.1 5.2.102.3
DM WorkFlow Web Server 5.2.1 5.2.102.1
7.3 DM WorkFlow Server
DM WorkFlow Server 5.2.1 5.2.102.10
DM API 5.2.1 5.2.102.16

7.4 DM WorkFlow Server

Language Pack

Lang Pack i Enc i English Canadian

5.2.102.5

Lang Pack i Frc i French Canadian 5.2.102.5
Lang Pack i Enu i English 5.2.102.5
Lang Pack i Frai French 5.2.102.5
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7.5 DM Extensions Server Setup

DM Extensions 5.2.1 5.2.102.47
DM API15.2.1 5.2.102.16
DM WorkFlow Client 5.2.1 5.2.102.10
DM AutoUpdate 5.2.1 5.2.102.1
DM Extension for AutoCAD 5.2.1 5.2.102.1
Imaging Client 5.2.1 5.1.0.5309
RM Client 5.2.1 5.2.102.3

7.6 RM Administration Tool

RM Administration Tool 5.2.1 5.2.102.13

DM API5.2.1 5.2.102.16

7.7 Automated E-mail Management

Automated E-mail Management 5.2.1 5.2.102.1

Addressable Folders 5.2.1 5.2.102.1
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Chapter 8

Files Delivered

Click here for a list of files included in the DM 5.2.1 CU?2 release.
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