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Chapter 1 

Introduction 

The following release notes state known problems and last minute changes to Open Text eDOCS 
DM Version 5.2.1 CU3. We recommend that you read these Release Notes in conjunction with the 
documentation included with the software package.  If any conflicts exist, the Release Notes 
supersede the other documentation. 

Check the Open Text Knowledge Center at (https://knowledge.opentext.com/) for any patches or 
documentation updates that may have been posted after the initial release of this version of DM 5.2.1 
CU3. 

1.1 Contact Information 

Open Text Corporation 

275 Frank Tompa Drive, Waterloo, Ontario, Canada, N2L 0A1 

Tel: +1-519-888-7111  
Toll Free Canada/USA: 1-800-499-6544 International: +800-4996-5440  
Fax: +1-519-888-0677   
E-mail: support@opentext.com  
FTP: ftp://ftp.opentext.com  
For more information, visit http://www.opentext.com 

 

https://knowledge.opentext.com/
http://knowledge.opentext.com/
mailto:support@opentext.com
ftp://ftp.opentext.com/
http://www.opentext.com/
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2 Chapter 2 

About Open Text eDOCS DM 5.2.1 CU3 

2.1 General Information 

The DM 5.2.1 CU3 release is cumulative and contains everything that earlier DM 5.2 and 5.1.0.5 
service or maintenance releases contained, plus any new modifications.  

These service releases automatically detect the products you have installed and apply service 
releases accordingly. For example, if you have DM Server but do not have RM Server, only DM 
Server service releases will be applied.  

Service releases within this set may have interdependencies. If you encounter issues, be sure that 
you have applied all service releases in this set and continue to reproduce the problem before 
contacting Technical Support. 

Please see Fixed Issues and Fixed Issues in Previous Releases for details on the public patches 
included in this release. 

2.2 Enhancements 

The DM 5.2.1 CU3 release contains the following enhancements: 

2.2.1 Customize Circular Reference Check* 

The registry key: HKLM\Software\Hummingbird\DOCSFusion\CircRefCheckDepth was added to 
specify the depth of levels checked for circular references when adding items to a folder.  
Configuration information can be found in DM/RM 5.x Documentation Updates  

https://knowledge.opentext.com/knowledge/llisapi.dll/12737505/DM_5.1.0.5_and_RM_5.1.0.5_-_Documentation_Updates.pdf?func=doc.Fetch&nodeid=12737505&viewType=1
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2.2.2 Outlook Views Descriptor* 

 

A new Outlook view descriptor which saves user customizations such as column formatting and 

fonts has been added.  The file, DMViews.dat, used to store the information can be found under 

<User Directory>/Hummingbird/DM/Settings.  This .dat file is dynamically generated upon first 

usage of the Outlook integration.  With this change users will see that all the customizations done on 

a folder view is maintained when they return to it.  In addition, administrators can customize the 

view and then push the DMViews.dat file to the clients. 

 

A known issue with this approach is that if user adds a new column in Explorer, Outlook will not 

display it unless you delete the DMViews.dat.  

2.2.3 Updated Recent Edits SQL Query Statement* 

The SQL Query used to retrieve a users recently edited items has been converted from two SQL 

queries to one query. 

 

2.2.4 Retain Save UI Size Settings* 

When the SaveUI is resized so that it is larger than the default minimum, those settings will 
automatically be saved in the user’s SaveUIConfig.xml file so that they can be used on subsequent 
saves.  

2.2.5 Ability to Display the Security Panel from the Profile 

Form* 

The ability to display the security controls on the profile form has been added to the Save UI.  To 
display the security controls on the profile form, the following edits must be made to the 
SaveUIConfig.xml file: 

<UseAccessDialogOnForm>True</UseAccessDialogOnForm> 

<SecurityPanelVisible>False</SecurityPanelVisible> 

Note that if both are set to True, you will see both security panels. 
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2.2.6 Performance Increases when Displaying the Save UI 

dialog* 

Code has been added to increase the performance when displaying the Save UI dialog.  Performance 
enhancements should be seen during the following events: saving from within applications such as 
Microsoft Word, importing documents from within DM Extensions and Outlook Extensions and 
drag and dropping documents into Outlook and/or DM Extensions. 

2.2.7 Provide a Warning to the User when a Document 

Becomes Unmanaged* 

Using COM integration, the following error will be displayed if a user attempts to save an eDOCS 
DM document that has become unmanaged: 

"This document has become unmanaged in DM and you may lose edits if you continue to save 
further edits and exit this document. Please perform a File->Save As to your desktop and contact 
your DM administrator as soon as possible. " 

In addition, if the user attempts to close the document without saving it the above error message will 
display again.  

Note that this does not apply to applications integrated via ODMA or Interceptor. 

2.2.8 Support for Microsoft Internet Explorer 8* 

eDOCS DM Client and DM Webtop are both supported when using Microsoft Internet Explorer 8. 

2.2.9 Support for Microsoft SQL Server 2008* 

Microsoft SQL Server 2008 in compatibility mode is supported for eDOCS DM databases.  See the 
configuration notes for setup and usage information. 

2.2.10 Support for Lotus Notes 8.5* 

eDOCS DM 5.2.1 CU3 supports Lotus Notes 8.5 with the following configurations: 
 
eDOCS DM 5.2.1 CU3 Lotus Notes Extensions + Lotus Notes 8.5 Basic Configuration 
eDOCS DM 5.2.1 CU3 Lotus Notes Small Footprint + Lotus Notes 8.5 Basic Configuration 
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eDOCS DM 5.2.1 CU3 Lotus Notes Small Footprint + Lotus Notes 8.5 Standard (Eclipse) 
Configuration 
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3 Chapter 3 

Packaging and Documentation 

3.1 Documentation 

The documentation and help files in DM 5.2.1 CU3 are those delivered with DM 5.1.0.5 SR1. Consult 
these for the core documentation set; however, you must also read the following documents to 
obtain new or corrected documentation: 

 New Documentation—The Open Text - Using eDOCS DM 5.2x Software document contains 
specific information related to this release, including using Microsoft Office 2007, Windows 
Vista, Dynamic Views, DM Extension for Lotus Notes, and the new save user interface. This 
new information is not located within the original core documentation set.  

 New Documentation and Updates—The DM/RM 5.x Documentation Updates document 
contains new and updated documentation since the original release of DM 5.1.0.5 and DM 
5.2, including information as a result of service releases and maintenance releases. This 
document also contains clarifications to existing documentation. 

3.1.1 Documentation Updates* 

The following documentation updates have been published in the Using DM 5.2x Software and 

DM/RM 5.x Documentation Updates documents: 

Using DM 5.2x Software  

The Using DM 5.2x Software guide has been updated to show the differences between active and 

passive inÛÌÎÙÈÛÐÖÕɯÌÕÈÉÓÌËɯÖÙɯËÐÚÈÉÓÌËɯÐÛÌÔÚɯÐÕɯ"ÏÈ×ÛÌÙɯƘȮɯɁ1ÌÎÐÚÛÙàɯ*Ìàɯ"ÖÕÍÐÎÜÙÈÛÐÖÕɯ2ÌÛÛÐÕÎÚɯÍÖÙɯ

,ÐÊÙÖÚÖÍÛɯ6ÖÙËȮɯ$ßÊÌÓȮɯÈÕËɯ/ÖÞÌÙ/ÖÐÕÛɯƖƔƔƛȭɂɯ 

 

http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/UsingDM52Guide.pdf
https://knowledge.opentext.com/knowledge/llisapi.dll/12737505/DM_5.1.0.5_and_RM_5.1.0.5_-_Documentation_Updates.pdf?func=doc.Fetch&nodeid=12737505&viewType=1
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Also, in the Using DM 5.2x Software guide, Chapters 10, 11, and 12 have been updated to show that 

the Contents tab has been removed from the Document Information window in Microsoft Word, 

Excel, and PowerPoint 2007. (DM-17136) 

DM/RM 5.x Documentation Updates  

Ɂ#,ɯ ËÔÐÕÐÚÛÙÈÛÐÖÕɯ&ÜÐËÌɂ 

 Ability to Disable the Unmanaged Document Notification  

 Bypassing Multi-Level Circular Reference Checks  

 Using Mixed and Windows Authentication for SQL Server Authentication  

Ɂ4ÚÐÕÎɯ#,ɯ$ßÛÌÕÚÐÖÕÚɂ 

 Contents Tab in Document Information Window  

3.1.2 Windows Help (WinHelp) Not Included in Windows Vista 

The Help files delivered with DM 5.2.1 were originally created in Windows Help (WinHelp) format. 
The Windows Help format is not supported, nor included, with Windows Vista operating systems. 

You can download the WinHelp.exe application and use it to view DM Help files on Windows Vista 
operating systems. Download the Winhelp.exe application from Microsoft’s web site at the following 
location: http://go.microsoft.com/fwlink/?LinkID=82148.  

However, the following known issue has been reported by Microsoft. When you open a Help topic 

(by pressing F1 or by selecting Help>Contents and Index), the following error message appears: 
“There was a problem running the macro. (1037).” After this initial error, you can continue using the 
Help files.  

For more information and workarounds to this issue, consult Microsoft’s Article ID 917607 at the 
following location: http://support.microsoft.com/kb/917607. 

The Help files do not contain any new information for DM 5.2.1 CU3. You must consult 
the Open Text - Using eDOCS DM 5.2x Software and DM/RM 5.x Documentation Updates 
documents for all new information pertaining to this release

http://go.microsoft.com/fwlink/?LinkID=82148
http://support.microsoft.com/kb/917607
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/UsingDM52Guide.pdf
https://knowledge.opentext.com/knowledge/llisapi.dll/12737505/DM_5.1.0.5_and_RM_5.1.0.5_-_Documentation_Updates.pdf?func=doc.Fetch&nodeid=12737505&viewType=1
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4 Chapter 4 

Installation and Upgrade Notes 

All updates in the DM 5.2.1 CU3 set are provided when you download dm52103.exe. When you 
download the releases, they are by default extracted to C:\Program 

Files\Hummingbird\Enterprise 2004 Service Releases\DM 5.2.103\Build 38. You can change the 
installation path, if you want. When the download is finished, the Hummingbird maintenance 
release browser automatically launches. You can download the release set for each server that you 
update, or you can download the release set to a shared network location. If you are running from a 
network location, double-click \Enterprise2004 DM 5.2.103\Build 38\setup.exe to launch the 
maintenance release browser. 

NOTE: As any combination of DM 5.x  products can exist on one machine, you must apply the 
DM 5.2.1 patch for each component.  

All server updates include the DM API updates. The DM API updates are also included with the 
DM Extensions updates for client machines. 

In addition to the instructions that follow, please be sure to review the Configuration Notes and the 
Fixed Issues and Known Issues lists for setup instructions that may be applicable to your DM 
implementation. 

4.1 Running Library Generator 

If you are upgrading from a previous version of DM 5105, after you install DM 5.2.1 CU3, you must 
run Library Generator (tblcomp.exe) in order for new and changed tables and columns to be 
updated. 

For a complete list of these tables and columns introduced in DM 5.2, consult the DM 5.2 Release 
Notes. The “Database Schema Changes” section contains the descriptions and values for each table 
and column. 

 

http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf
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4.2 DM Server 

DM Server 5.1.0.5 SR1 or later must be installed before the updates can be applied. The maintenance 
release installation will validate the licensing to determine which products are installed and only 
update patched files.  

On the DM Server being updated, from the maintenance release browser, click Install Products>DM 

Server.  

 

Installation Considerations  

 The DM Server maintenance release installation shuts down the DM Service, loads the 
updated files, and restarts DM Server. If you cannot connect to clients after the update is 
run, verify that the Server State in the DM Server Manager is Started. At the end of the DM 
Server installation, you may receive a Reboot Required notice. Reboot the DM Server to 
complete the installation. 

 Before installing the DM Server updates on a server that is indexing with SearchServer™, all 
SearchServer indexes must be stopped through DM Server Manager and restarted after the 
installation is complete.  

 If either DM Web Server or DM Extensions is installed on DM Server, it must be shut down 
to release connectivity with the DM API. For DM Extensions, close all applications and be 
sure that Interceptor has also been closed. For DM Web Server, you must shut down the IIS 

Admin Service in Control Panel>Services. After the maintenance release installation is 
complete, remember to restart the IIS Admin Service and all appropriate Web services.  

 If InstallShield detects processes that cannot be released during the installation process, a 
reboot will be required after the updated files are copied. After the reboot, all maintenance 
release files will be updated. The Server Configuration Wizard may launch. If you do not 
need to change your configuration, click Cancel.  

 If you need to Repair or Modify your DM Server installation, uninstall the software from 
Control Panel>Add/Remove Programs. A reboot is required before you reinstall. When 
reinstallation is complete, you will also need to reinstall applicable DM service or 
maintenance releases.  
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4.3 DM Web Server 

DM Web Server 5.1.0.5 SR1 or later must be installed before the updates can be applied. The 
maintenance release installation will validate the licensing to determine which products are installed 
and only update patched files.  

DM Extension Server Setup update must be run after updating DM Web Server in order to update 
the DM Extensions. 

On the DM Web Server being updated, from the service release browser, click Install Products>DM 

Web Server.  

 

Installation Considerations  

If you currently have custom directories for your users or groups, you will need to copy the 
appropriate files from the \Cyberdocs\Backup directory to your custom directories after the update 
has been installed.  

Hummingbird DM Web Server 5.2.103 can be uninstalled from Control Panel>Add/Remove 

Programs. 

Later, if you choose to Modify or Repair your DM Web Server installation from the CD image, you 
will need to uninstall DM Web Server 5.1.0.5 SR1, make your Modify or Repair changes, and then 
reinstall. 

4.4 DM WorkFlow Server 

DM WorkFlow 5.1.0.5 SR1 or later must be installed before the updates can be applied.  

On the server being updated, from the maintenance release browser, click Install Products>DM 

WorkFlow Server.  

 

Installation Considerations  

DM WorkFlow Server updates must be applied before updating the DM WorkFlow clients. 

Later, if you choose to Repair or Modify your DM installation from the CD image, you will also need 
to reinstall applicable the DM WorkFlow updates.  
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4.5 DM Extensions Server Setup  

DM Extensions Server Setup 5.1.0.5 SR1 or later must be installed before the updates can be applied.  

On the server being updated, from the maintenance release browser, click Install Products>DM 

Extensions Server Setup.  

 

Installation Consideration  

After the service release for the DM Extensions Server Setup has been installed, users can log on to 
the DM Webtop to upgrade DM Extensions on the client machines. 

4.6 RM Administration Tool 

RM Administration Tool 5.1.0.5 SR1 or later must be installed before the updates can be applied. 

On the server or workstation being updated, from the maintenance release browser, click Install 

Products>Hummingbird RM Administration Tool. 

 

Installation Note:  

Later, if you choose to Repair or Modify your RM Administration Tool installation from the CD 
image, you will need to reinstall the RM Administration Tool 5.1.0.5 updates. 

4.7 Installing DM Imaging on Windows Vista 

After you install DM Imaging on a Windows Vista operating system, you must apply a patch to the 
client workstation. This patch is located in C:\Program Files\Hummingbird\Enterprise 2004 

5.2.103\Build 38\Tools\DM Extensions\Imaging directory. Copy all files to the ..\DM Extensions 

directory.
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5 Chapter 5 

Configuration Notes 

5.1 New Behavior for Removing Date Entries on the 

Profile Form* 

As of DM 5.2.1 CU3, the following can be used to remove entries on profile form date fields.  This 
will remove the date from both the profile form and the database: 

Control + 0  
Control + Delete  
Clear in the calendar  

5.2 Updates to DM Designer and Profile Form 

Customizations* 

The following changes have been made in support of eDOCS DM Designer and Profile form 
customizations.  This was included in eDOCS DM 5.2.1 CU2 Hotfix 1. 

Options NOT SUPPORTED 

 HELP ID  

 Relative X 

 Relative Y 

 Relative Width 

 Relative Height  

 Opaque (for boxes only) 

 Button  
o Bitmaps (up and down bitmaps) 
o Button Text position 

Options SUPPORTED 
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Form Field Options  

 

 Field Name 

 Prompt string (supports Accelerator characters) 

 Type 

 Max Characters ( for character fields only) 

 All Alignment options (Prompt Location, Prompt Alignment, and Input Alignment) 

 Validation 
o Range val1 val2  
o Error Message 
o MATCH masking for a text box 

 Format String 

 Lookup support  

 Prompt (Foreground, Background and Font, Border (see below) ) 

 Input (Foreground, Background and Font, Border (see below)) 

 All Lower 

 Password 

 All Upper 

 Read-Only 

 Hidden 

 Disabled 

 Required 

 Multi-Line  
o Allow Tabs 
o V Scroll 
o H Scroll 
o Word Wrap 

 Left Text (available for Checkbox) 

 On/Off Values (for Checkboxes only) 

 RadioButton values (for Radiogroup only) 

Borders 

 

Field type/option Translates to in new interface Comments 

Text Boxes   

       Field Borders   
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None No border  

Thin Recessed, Etched  Windows Fixed 3D border   

All other borders styles Windows FixedSingle border Includes the following border 
styles: 

Thin, Thick, Underline, 
Shadow, Raised, Recessed, 
Thin Raised, Button Up, 
Button Down, Def Button Up, 
Def Button Down, Combo Up, 
Combo Down  

       Input Field Borders   

None No border  

Thin Recessed  Style3D border   

Etched Simple border  

All other borders styles Default border (which is based 
on Windows Style 

Includes the following border 
styles: 

Thin, Thick, Underline, 
Shadow, Raised, Recessed, 
Thin Raised, Button Up, 
Button Down, Def Button Up, 
Def Button Down, Combo Up, 
Combo Down  

Group Boxes & RadioGroup   

None No border  

Thin  ButtonBorderStyle.Solid border  
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Etched Border3DStyle.Flat border  

All other borders styles Default border  Includes the following border 
styles: 

Thick, Underline, Shadow, 
Raised, Recessed, Thin Raised, 
Thin Recessed, Button Up, 
Button Down, Def Button Up, 
Def Button Down, Combo Up, 
Combo Down  

Check boxes, Labels   

No border support yet No border  

Line All lines are created using a 
Fixed3d border style to show 
the line 

 

 

5.3 Support for Microsoft SQL 2008* 

To use Microsoft SQL Server 2008, copy the addlib.exe and tblecomp.exe from the patch’s 
../Tools/DM Server/ENU directory.  Note that these executables are available for English only 
environments.  In order to use Microsoft SQL 2008 with eDOCS DM, the ntwdblib.dll must be 
present in the c:\windows\system32 directory.  This file is installed with SQL Server 2000 or earlier 
versions and is not available with SQL Server 2005 or SQL Server 2008 installations. 

5.4 Enhancing Application Integration Stability 

In addition to specific fixes outlined in these Release Notes, DM 5.1.0.5 and subsequent releases 
focused on enhancing application integration stability. In conjunction with the recommended 
registry settings outlined below, significant improvements have been made in error handling related 
to zero-byte files and other file save anomalies. These registry settings must be manually applied to 
function correctly with DM 5.2.1. If DM detects that a save or upload process fails, an error message 
will alert the user, the user will be notified in screen-displayed messages, and the Retry option will 
occur until the file is saved successfully or the user cancels the action. If the native application's Auto 
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Recovery is activated by an application failure, analysis of the problem will be outside the scope of 
DM error detection, and users should follow normal application procedures to recover their 
document.  

Manually apply the registry settings below: 

[HKEY_CURRENT_USER\Software\Hummingbird\PowerDOCS\Core\Plugins\Fusion\Settings] 

"CheckFileSizeOnDownload"=dword:00000002 

"CheckFileSizeAfterUpload"=dword:00000001 

"RetryUploadIfFailed"=dword:00000001 

"RetryUploadDelay"=dword:0000000f 

"UploadIfDifferentSizeOnDownload"=dword:00000001 

"UploadIfDifferentSizeOnUnlock"=dword:00000001  

NOTE: Additional information is available in Technical Bulletin #133277, “How to Avoid Missing 
Edits and Zero-Byte Files in Hummingbird DM™”. This document is available in the Open Text 
Knowledge Center at https://knowledge.opentext.com. 

5.5 Addressable Folders 

If you are sending e-mails via Addressable Folders to both primary and remote DM libraries, an 
address for a primary library folder must be first in the list. 

The DM SMTP Service cannot coexist on the same server where Microsoft or other SMTP services 
are running. 

During installation of Addressable Folders, verify that the Administrative Tools dialog boxes 
pertaining to server services are closed. If any are open, some services cannot be unregistered, and 
the installation will not be successful. 

5.6 Implementing Content Cache 

As of DM 5.1.0.5 SR6, Content Cache was enhanced to allow users to save the document to a Content 
Cache Server and then have immediate access to the document. The Cache Server handles 
synchronization of document updates to the document server in the background. These actions can 
greatly increase the efficiency of saving documents from a remote site.  

Implementation of this optional enhancement requires running a SQL script and modifying a 
registry entry. Complete the steps listed below. 

To implement the Content Cache feature: 

https://knowledge.opentext.com/
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1 Using Microsoft SQL Query Analyzer, run the script content_cache.sql, which is located in the 
\Tools\DM Server folder, for all Hummingbird DM libraries. If the owner of the library is not 
DOCSADM, replace DOCSADM in the script with the database owner. 

2 In DM Server Manager, verify that Commit Transaction Monitoring is enabled. On the Content 

Cache tab, verify that Enable Content Cache is selected and the Content Cache settings are 
correct. 

3 Create the following values in the registry key on the DM Server machine: 

[HKEY_LOCAL_MACHINE\SOFTWARE\Hummingbird\DOCSFusion\Content Cache] 
"Cache"="Enabled" 
"Max Size"=dword:000001f4 
"Lazy Write"="Enabled" 
"Location"="C:\\content_cache\\" 

4 Set the Location for your Content Cache. 

5 Restart DM Server. 

5.7 DM Extension for Lotus Notes 

Because each Lotus Notes document and e-mail message is associated with a Lotus Notes form 
template, you should not archive, delete, or move the associated form. This form determines how 
the document or e-mail message is displayed and becomes a related document in DM. 

When a user opens a profiled Lotus Notes document, if the related profiled Lotus Notes form cannot 
be located in DM, the document opens and uses the existing Lotus Notes form located in the Lotus 
Notes database. This means that if the form has changed, the document will not render in its original 
form. 

You should advise your users not to delete the Lotus Notes form template documents. 

5.8 DM Extensions API Connections 

In DM 5.1.0.5 SR6 and later, the DM Extensions API takes a new approach for tracking active DM 
Extensions API connections. To bring their code into conformance with this new approach, 
developers should introduce the following before using DM Extensions API interfaces: 

Instantiate an object of either IBCSession or IBCSession2.  

Call the method Logon (for IBCSession) or LogonEx (for IBCSession2) if IBCBrowser object is not 
available. 



 

  Open Text eDOCS DM Version 5.2.1 CU3 Release Notes 25 
  

 

 

The session object can be released only when no more DM Extensions API usage is planned, or there 
are other connected session objects.  

5.9 DM Indexer Considerations 

This release contains SearchServer 6.1.0.167. When upgrading from DM 5.1.0.5 SR6 MR5 or earlier, 
you must create new indexes of your DM Libraries. We recommend that you configure one indexing 
server to build your new indexes before deploying DM 5.2.1 to client workstations. Alternatively, 
you can select previous releases of SearchServer indexes for client searching while you build the 
indexes; however, these indexes must be static and cannot be updated by SearchServer 6.1.0.167 
during the transition. You can also create indexes before rolling out the upgrade to clients. 

The Hybrid Searches feature, which was introduced in DM 5.1.0.5 Service Release 5, can be 
implemented in DM 5.2.1 CU3. The DM/RM 5.x Documentation Updates document contains 
detailed instructions on implementing Hybrid Searches (Profile and Content searches) in the 
“Improved Performance for Hybrid Searches” section. If you choose to implement Hybrid Searches 
with DM 5.2.1 CU3, apply the update before recreating your DM indexes. If you add Hybrid 
Searches after you create your SearchServer 6.1.0.167 indexes, reindexing is required. 

 

NOTE: Hybrid Searching is supported for MS SQL and Oracle DM libraries.  

5.10 Dynamic Views 

5.10.1 Converting from DVDP in DM 5.1.0.5 to Dynamic Views 

in DM 5.2.1 

DM 5.2 introduced a new version of Dynamic Views. When you install Dynamic Views 5.2.1 on the 
client machine, the DM 5.1.0.5 version of Dynamic Views Dynamic Profiling (DVDP) is 
automatically removed. Refer to the Using Open Text ð eDOCS DM 5.2x Software document for 
information on converting a current DVDP environment to the new Dynamic Views for 5.2. The 
conversion process allows DVDP 5.1.0.5 clients (DM 5.1.0.5 SR5 and SR6) to continue using their 
current version of DVDP until they are upgraded to DM 5.2.1. 

5.10.2 Search Objects 

In order for search objects to function correctly in Dynamic Views, the MSG_ITEM field must be 
placed on the QBE search form (DEFQBE.FRM, GOVTQBE.FRM, BANKQBE.FRM, or 
LAWQBE.FRM). When you create a new library, this process is done automatically; however, if you 
upgrade a DM 5.1.0.5 library to DM 5.2.x, you must manually add this field to the applicable QBE 
search form using DM Designer. 

To add the MSG_ITEM field to the QBE search form: 
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1 Click Start>Programs>Hummingbird>DM Server>Server Admin Tools>DM Designer. 

2 Click Profiles. 

3 In the Available Forms dialog box, select your industry type’s QBE Search Form, and then click 
OK . For example, select LAWQBE Legal QBE Search Form. 

4 In the SQL Columns dialog box, select MSG_ITEM and drag it to the Search Form. 

5 Release the mouse where you want the MSG_ITEM field to appear. 

6 Select File>Save. 

7 In the Save Form dialog box, click OK. 

8 Select File>Exit to exit DM Designer. 

9 Refresh the cache in DM Server Manager. 

 

5.10.3 Last Edit Date/Time Deviation 

Dynamic Views Search objects return a last edit date/time that deviates one hour or more from the 
actual edit date.  This issue has been resolved in DM 5.2.1 CU2, however the LAST_EDIT_TIME 
column must be added to the hit list in order for the fix to take effect.  Be sure to refresh the DM 
Server and Workstation caches for the changes to the form to appear. 

5.11 Microsoft Office 2007* 

The Microsoft Office 2007 redistributables are required if you select Office 2007 integration. These 
redistributables are installed automatically; however, they will not be removed when DM is 
uninstalled from the machine.  

Please refer to the DM 5.2.1 HF1 Release notes for additional Office 2007 configuration information, 
which can be found here: 
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM521HF1ReleaseNotes.pdf 

As of DM 5.2.1 CU3, the Contents tab has been removed from the Document Information window 
within Office 2007.   

Office 2007 SP2 was tested and is supported in conjunction with DM 5.2.1 CU3. 

http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM521HF1ReleaseNotes.pdf
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5.11.1 Microsoft Excel COM Automation Using Non-English 

Regional Settings 

If you use active or passive COM Automation integration with Microsoft Excel, and your operating 
system’s regional settings are set to non-English (United States), you must apply the Microsoft Office 
Language Pack in order to save native .csv files. 

The Microsoft Office Language Pack(s) are located on Microsoft’s web site at the following location: 
http://office.microsoft.com/en-us/downloads/HA011133501033.aspx 

5.11.2 Ensuring Application Integration Works When You Do 

Not Install All Microsoft Office 2007 Applications  

If you do not install all Microsoft Office 2007 Basic applications (Word, Excel, and PowerPoint), 
application integration is broken; however, you can use a workaround to ensure that DM application 
integration works after installing only one or two of the applications.  

To implement the workaround: 

1 In Control Panel>Add or Remove Programs, select Microsoft Office 2007 Primary Interop 
Assemblies, and then click Remove. 

2 Select Start>Run, type regedit , and then click OK. 

3 In the Registry Editor, create the following registry keys: 
ï HKEY_CLASSES_ROOT\TypeLib\{00020813-0000-0000-C000-000000000046}\1.6  

  (Default) Value: Microsoft Excel 12.0 Object Library 

ï HKEY_CLASSES_ROOT\TypeLib\{00020905-0000-0000-C000-000000000046}\8.4  
  (Default) Value: Microsoft Word 12.0 Object Library  

ï HKEY_CLASSES_ROOT\TypeLib\{91493440-5A91-11CF-8700-00AA0060263B}\2.9  

  (Default) Value: Microsoft PowerPoint 12.0 Object Library  

4 Reinstall the Microsoft Office 2007 Primary Interop Assemblies using Microsoft’s redistributable 
package. You should read the package’s readme for additional information. Download the 
Microsoft redistributable package from Microsoft’s web site at the following location: 
http://www.microsoft.com/downloads/details.aspx?FamilyID=59daebaa-bed4-4282-a28c-
b864d8bfa513&DisplayLang=en  

5.12 .NET Framework 2.0 

The .NET Framework 2.0 is a prerequisite for all products.  This must be downloaded from 
Microsoft’s website prior to eDOCS DM installation. 

You must install .NET Framework 2.0 on both the client and server machines. 

http://office.microsoft.com/en-us/downloads/HA011133501033.aspx
http://www.microsoft.com/downloads/details.aspx?FamilyID=59daebaa-bed4-4282-a28c-b864d8bfa513&DisplayLang=en%20
http://www.microsoft.com/downloads/details.aspx?FamilyID=59daebaa-bed4-4282-a28c-b864d8bfa513&DisplayLang=en%20
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5.13 Oracle Hybrid Searching 

Oracle is supported in hybrid searching. The hybrid search enhancement changes the way in which 
the INDEX table uses metadata when performing a hybrid search, which is a search that contains 
both profile and content search criteria.  

The following files are delivered in the \Enterprise 2004 5.2.103\Tools\DM Server\Profile-

Content Search directory: 

 Oracle_indexed_columns_dm.sql - This should be run on a DM-only server where RM is 

not installed. 

 Oracle_indexed_columsn_rm.sql - This should be run on a DM/RM server. 

Run the appropriate file depending on your setup. 

For complete instructions on using hybrid searching, for both Oracle and Microsoft SQL databases, 
consult the "Improved Performance for Hybrid Searches" section in the DM/RM 5.x Documentation 
Updates document. 

5.14 Save User Interface Behavior with RM File Parts 

When a user saves to a RM file part, that file part will not appear in the Location drop-down menu 
unless the user has previously browsed the file part in the save user interface or through DM 
Extensions. 

For example, when a user starts an integrated application and saves a document to a RM file part, 
while the DM session is active, that file part will appear in the Location drop-down menu. However, 
once the user exits and restarts DM, the file part will not appear. 

5.15 Support for Microsoft Office XP 

Although Microsoft Office XP is not listed as a supported application for DM 5.2.1 CU3, we have 

performed minimal testing with Microsoft Office XP and determined that integration is possible. 

Open Text encourages customers to upgrade to Microsoft Office 2003 or Microsoft Office 2007 before 

deploying DM 5.2.1 CU3; however, if that is not possible, we will continue to accept support cases 

from customers using DM 5.2.1 CU3with Microsoft Office XP.   

https://knowledge.opentext.com/knowledge/llisapi.dll/12737505/DM_5.1.0.5_and_RM_5.1.0.5_-_Documentation_Updates.pdf?func=doc.Fetch&nodeid=12737505&viewType=1
https://knowledge.opentext.com/knowledge/llisapi.dll/12737505/DM_5.1.0.5_and_RM_5.1.0.5_-_Documentation_Updates.pdf?func=doc.Fetch&nodeid=12737505&viewType=1
https://knowledge.opentext.com/knowledge/llisapi.dll/12737505/DM_5.1.0.5_and_RM_5.1.0.5_-_Documentation_Updates.pdf?func=doc.Fetch&nodeid=12737505&viewType=1
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Consult the Using Livelink ECM ð eDOCS DM 5.2x Software guide for the “Supported Applications 
and Platforms in DM 5.2” chapter. 

5.16 Support for Microsoft SQL Server 2005 

Support for Microsoft SQL Server 2005 is provided in compatibility mode and can be attained by 
running Library Generator against the database. Locate the tblcomp.exe file in the ..\Program 

directory.  

5.17 Support for Microsoft Windows 2003 Server SP1 

Support for Windows 2003 Server SP1 began in DM 5.1.0.5 SR5. With the installation of DM 5.2 or 
greater, the necessary files are delivered for support of Microsoft Windows 2003 Server SP1. You will 
need to run the DM Server Configuration Wizard after applying the 2003 Server Service Release. 

5.18 Support for Oracle 10g Release 2 

Support for Oracle 10g Release 2 is provided with DM 5.2.1. No further action is required after you 
run Library Generator to upgrade from DM 5.1.0.5 to DM 5.2.1.  

Oracle 10G Release 2 is supported with the following Oracle patches installed: 

 Oracle 10g Release 2 patch set 10.2.0.3.0 (Oracle patch number 5337014) 

 Oracle ODBC drop-ins (Oracle patch number 5699495) 

Please contact Oracle support for additional information.  Note that these patches are included with 
Oracle 11G. 

5.19 Update Deployment Packages Created Prior to DM 

5.2.1  

Any deployment Packages that were created prior to DM 5.2.1 will need to be updated. Edit your 
existing deployment packages, re-enter your administration credentials, select the correct 
components, and execute a Save before using the package. 

After you install DM 5.2.1 CU3, you should run the Deployment Package Wizard and resave all 
deployment packages that use the “Run as Administrator” option. 

http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/UsingDM52Guide.pdf
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To resave a deployment package: 

1 Click Start>Programs>Hummingbird>DM Extensions Server Setup>Deployment Package 
Wizard. 

2 Select a deployment package that has the Run as Administrator option enabled, which is 
displayed in the Details box. 

3 Click Edit to edit the deployment package. 

4 In the Location Information dialog box, click Next. 

5 In the User Information dialog box, type the administrator credentials to be used by the 
deployment package, and then click Next. 

6 Continue clicking Next on all subsequent dialog boxes, and then click Save. 

7 Repeat the above steps for all deployment packages using the Run as Administrator option, and 
then exit the wizard.  

5.20 Upgrading or Changing Integration Methods 

When you upgrade or change your integration method (ODMA, COM, Passive, Active, or 
Interceptor) for an application, some menu items might be unavailable, appear twice, or do not work 
as expected.  

This is working as designed to prevent other potential integration issues, such as performance 
issues, conflicts with third-party macros, and saving and read-only issues with the normal.dot file in 

Microsoft Word. You can resolve this issue by resetting the toolbars. In addition be sure to verify 

that your launch methods are correct as they can vary between application versions. 

To resolve the menu issue: 

1 Start the application that has unavailable, duplicate, or non-functioning menu options. 

2 Select Tools>Customize. 

3 In the Toolbars tab, select Standard, and then click Reset. 

4 Select Menu Bar, and then click Reset. 

5 In Microsoft Word, click OK when you are prompted to reset changes in the normal.dot file. 

NOTE: Customizations to the toolbar will be lost by resetting the toolbar.  

5.21 User Account Control (UAC) Setting in Windows 

Vista 

The User Account Control (UAC) setting in Windows Vista operating systems is enabled by default. 
The following issues occur with this setting enabled: 
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 Error message appears when attempting to install DM Extensions from DM Webtop (DM-
9640) 

 DM Extensions cannot be launched if the Client Deployment Utility is launched first (DM-
10730) 

 A DM Server that is added from the DM Extensions Login screen is not retained (DM-10726) 

For more information about the UAC setting, please consult the Microsoft support site at 
http://support.microsoft.com. 

5.22 Visual C++ 2005 SP1 

The Visual C++ 2005 SP1 redistributables are a prerequisite to DM Extensions, DM Server, and all 
server-side products that require the DM API. For server-side patch installations, the DM 
administrator should be prompted to install this redistributable. 

For DM Extensions, the user will be prompted only for interactive installations. This redistributable 
will not be removed when DM is uninstalled from the machine.

http://support.microsoft.com/
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6 Chapter 6 

Fixed Issues and Known Issues 

Following is a list of the issues resolved in DM 5.2.1 CU3. For more information on an issue, go to 
the Open Text Knowledge Center and search on the Key number (such as DM-4124), which can be 
found at the beginning of the title, or you may contact Technical Support.  

6.1 Fixed Issues 

Click here for a list of all fixed issues in this release. 

6.2 Fixed Issues in Previous Releases 

You should review the Fixed Issues for all releases between the one you are upgrading from and this 
release. You can find this information in the following documents: 

 DM 5.1.0.5 Service Release 1 Release Notes 

 DM 5.1.0.5 Service Release 2 Release Notes 

 DM 5.1.0.5 Service Release 3 Release Notes 

 DM 5.1.0.5 Service Release 4 Release Notes 

 DM 5.1.0.5 Service Release 4 Maintenance Release 1 Release Notes 

 DM 5.1.0.5 Service Release 4 Maintenance Release 2 Release Notes 

 DM 5.1.0.5 Service Release 4 Maintenance Release 3 Release Notes 

 DM 5.1.0.5 Service Release 4 Maintenance Release 4 Release Notes 

 DM 5.1.0.5 Service Release 5 Release Notes 

 DM 5.1.0.5 Service Release 5 Maintenance Release 1 Release Notes 

 DM 5.1.0.5 Service Release 5 Maintenance Release 2 Release Notes 

 DM 5.1.0.5 Service Release 5 Maintenance Release 3 Release Notes 

https://knowledge.opentext.com/
https://knowledge.opentext.com/knowledge/llisapi.dll/fetch/2001/3551049/11569762/11568658/customview.html?func=ll&objId=11568658&objAction=browse&viewType=1#DMRM52
https://knowledge.opentext.com/knowledge/llisapi.dll/12826460/DM_5.1.0.5_-_DM_RM_5.1.0.5_Service_Release_1_Release_Notes.html?func=doc.Fetch&nodeid=12826460&viewType=1
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR2.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR3.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR1.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR2.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR3.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR4MR4.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR5.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR5MR1.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR5MR2.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/ReadmeDM5105SR5MR3.html


 

34 Open Text eDOCS DM Version 5.2.1 CU3 Release Notes    

 DM 5.1.0.5 Service Release 6 Release Notes 

 DM 5.1.0.5 Service Release 6 Maintenance Release 1 Release Notes 

 DM 5.1.0.5 Service Release 6 Maintenance Release 2 Release Notes 

 DM 5.1.0.5 Service Release 6 Maintenance Release 3 Release Notes 

 DM 5.1.0.5 Service Release 6 Maintenance Release 4 Release Notes 

 DM 5.2 Release Notes 

 DM 5.2.1 Release Notes 

 DM 5.2.1 HotFix 1 Release Notes 

 DM 5.2.1 CU1 Release Notes 

 DM 5.2.1 CU2 Release Notes 

 DM 5.2.1 CU2 HotFix 1 Release Notes 

 

6.3 Known Issues 

6.3.1 Application Integration 

Multiple integration issues when using specific Visio templates have been discovered with Visio 
2003/2007 integration including but not limited to: 

1.  Visio document remains checked out if the new document is closed using 
application’s "X" in the right hand corner or when using the right click --> Close on 
the task bar. 

2. In Visio 2007, VISIO.exe needs to be killed if a File --> Exit is performed on a Visio 
document without making any edits in order to close or exit the application. 

3. When using specific template in Visio 2007, DM and File menus appear to be grayed 
out. 

4. When saving certain Visio 2003 documents stored in eDOCS DM the native save as 
dialog may be displayed instead of the eDOCS DM Save UI. 

A case has been opened with Microsoft Support to help diagnose and resolve these issues. 

http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/sr6/readmedm5105sr6.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/sr6/readmedm5105sr6mr1.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/sr6/DM5105_SR6_MR2_Release_Notes.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/sr6/DM5105SR6MR3ReleaseNotes.html
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm5105/sr6/readmeDM5105sr6mr4.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM52ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/dm521releasenotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM521HF1ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM521CU1ReleaseNotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/dm521cu2releasenotes.pdf
http://mimage.opentext.com/support/ecm/secure/releasenotes/dm52/DM521CU2HotFixReleaseNotes.pdf
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6.3.2 DM Extensions 

DM-17051 – With eDOCS DM/RM installed, if an attempt is made to delete or edit a quick search 
item, a Cancel Request dialog will be displayed. 

6.3.3 Dynamic Views 

DM-17170 – Using DM 5.2.1 CU2 or CU3, when profiling a document using Dynamic Views in the 
navigational tree, the matter field on the profile form will be populated by the client’s system id.  
This appears to occur due to a corruption in the cache directory.   

Workarounds:  

Use balanced caching or if the issue occurs, choose cancel on the profile form and refresh the user 
cache.  The second approach will need to be performed every time a user logs into DM.  It is 
suggested to implement balanced caching. 
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7 Chapter 7 

Image Numbers 

7.1 DM Server 
DM Server 5.2.1 5.2.103.13 

DM Administration Tools 5.2.1 5.2.103.4 

RM Server 5.2.1 5.2.103.13 

DM API 5.2.1 5.2.103.13 

7.2 DM Web Server 
DM Web Server 5.2.1 5.2.103.6 

DM Web Administration Tools 5.2.1 5.2.103.5 

DM API 5.2.1 5.2.103.13 

RM Web Server 5.2.1 5.2.103.5 

DM WorkFlow Web Server 5.2.1 5.2.103.1 

7.3 DM WorkFlow Server 
DM WorkFlow Server 5.2.1 5.2.103.6 

DM API 5.2.1 5.2.103.13 

7.4 DM WorkFlow Server Language Pack  
Lang Pack ï Enc ï English Canadian 5.2.103.1 

Lang Pack ï Frc ï French Canadian 5.2.103.1 

Lang Pack ï Enu ï English 5.2.103.1 

Lang Pack ï Fra ï French 5.2.103.1 
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7.5 DM Extensions Server Setup 
DM Extensions 5.2.1 5.2.103.5 

DM API 5.2.1 5.2.103.13 

DM WorkFlow Client 5.2.1 5.2.103.6 

DM AutoUpdate 5.2.1 5.2.103.1 

DM Extension for AutoCAD 5.2.1 5.2.103.1 

Imaging Client 5.2.1 5.1.0.5309 

RM Client 5.2.1 5.2.103.5 

7.6 RM Administration Tool 
RM Administration Tool 5.2.1 5.2.103.18 

DM API 5.2.1 5.2.103.13 

7.7 Automated E-mail Management 
Automated E-mail Management 5.2.1 5.2.103.1 

Addressable Folders 5.2.1 5.2.103.1 
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8 Chapter 8 

Files Delivered 

Click here for a list of files included in the DM 5.2.1 CU3 release.  

https://knowledge.opentext.com/knowledge/llisapi.dll/fetch/2001/3551049/11569762/11568658/customview.html?func=ll&objId=11568658&objAction=browse&viewType=1#DMRM52

